1013 : [기초-입출력] 정수 두 개 입력받아 그대로 출력하기 with Swift

 

11. 콘솔에서 정수 두 개를 입력받아 그대로 출력하라.

두 개의 정수가 공백으로 구분되어 입력된다.

입력 예시

1 2

출력 예시

1 2

JAVA

1
2
3
4
5
6
7
8
9
10
11
12
import java.util.Scanner;
 
public class Main {
    public static void main(String[] args) {
        Scanner scanner = new Scanner(System.in);
        int value1 = scanner.nextInt();
        int value2 = scanner.nextInt();
        System.out.println(value1 + " " + value2);
        scanner.close(); 
    }
}
 
cs

 

Swift 4.2

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
import Foundation
 
func parseLine(str:String-> [Int]{
    var resultValue = [Int]()
    let temprorary = str.split(separator: " ")
    for sub in temprorary {
        if let value = Int(sub) {
            resultValue.append(value)
        }
    }
    return resultValue
}
 
let line = readLine()
if line != nil {
    let resultValue:[Int= parseLine(str: line!)
    if resultValue.count > 1 {
        print(String.init(format: "%d %d", resultValue[0],resultValue[1]))
    }
}
cs

 

 

솔직히 입력받는거에 readLine 말고 다른게 있을수도 있습니다;;

자바의 nextInt() 같은 편리한게요.

하지만 입력 부분을 대충 검색해봤는데 안보여서 그냥 readline으로 받고 스페이스를 기준으로 파싱해서 출력했습니다.

 

https://codeup.kr/problem.php?id=1013

 

[기초-입출력] 정수 두 개 입력받아 그대로 출력하기

int a, b; scanf("%d %d", &a, &b); printf("%d %d", a, b); 와 같은 방법으로 가능하다.

codeup.kr

 

//추가-

기존에 올렸던 블로그의 소스에서 한줄입력을 받고 나누는 부분을 따로 함수로 밖으로 빼내어 올리겠습니다

 

 

1014 : [기초-입출력] 문자 두 개 입력받아 순서 바꿔 출력하기 with Swift

12. 콘솔에서 두 개의 문자를 입력 받은 후 순서를 바꿔 출력하라.

입력 예시

A b

출력 예시

b A

JAVA

1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

19

import java.util.Scanner;

 

public class Main {

    public static void main(String[] args) {

        Scanner scanner = new Scanner(System.in);

        String line = scanner.nextLine();

        scanner.close();

        

        String[] words = line.split(" ");

        if(words.length == 2) {

            String resultString = new String();

            for (int i = words.length - 1; i >= 0--i) {

                resultString += " " + words[i];

            }

            System.out.println(resultString.trim());

        }

         

    }

}

Colored by Color Scripter

cs

 

Swift 4.2

1

2

3

4

5

6

7

8

9

10

11

12

import Foundation

let line = readLine()

if line != nil {

    var temporary = line!.split(separator: " ")

    temporary.reverse()

    

    var resultString = String()

    for sub in temporary {

        resultString.append(" \(sub)")

    }

    print(resultString.trimmingCharacters(in: .whitespaces))

}

Colored by Color Scripter

cs

 

스위프트는 이전과 비슷하게됐네요.

이번은 자바에서도 다른 좋은게 있지않을까 생각되지만, 찾아보기도 귀찮아졌습니다.

https://codeup.kr/problem.php?id=1014

 

[기초-입출력] 문자 두 개 입력받아 순서 바꿔 출력하기

char x, y; scanf("%c %c", &x, &y); printf("%c %c", y, x); //출력되는 순서를 작성 와 같은 방법으로도 해결할 수 있다.

codeup.kr

 

 

 

 

 

 

 

1015 : [기초-입출력] 실수 한 개 입력받아 소수점 이하 둘째 자리까지 출력하기 with Swift

 

13. 콘솔에서 실수(float)를 한 개를 입력받아 소수점 이하 3째 자리에서 반올림하여 2째 자리까지 출력하시오.

입력 예시

1.59654

출력 예시

1.60

JAVA

1

2

3

4

5

6

7

8

9

10

import java.util.Scanner;

 

public class Main {

    public static void main(String[] args) {

        Scanner scanner = new Scanner(System.in);

        Double value1 = scanner.nextDouble();

        System.out.println(String.format("%.2f", value1));

        scanner.close();

    }

}

Colored by Color Scripter

cs

 

Swift 4.2

1

2

3

4

5

6

7

8

import Foundation

let line = readLine()

if line != nil {

    if let floatValue = Double(line!) {

        let printValue = String.init(format:"%.2f", arguments: [floatValue])

        print(printValue)

    }

}

Colored by Color Scripter

cs

 

이전에 소수점자리 0으로 채우기에서 그냥 .2f로 변경한거네요..

https://codeup.kr/problem.php?id=1015

 

[기초-입출력] 실수 한 개 입력받아 소수점 이하 둘째 자리까지 출력하기

double로 변수를 선언한 경우 %.2lf로 출력하고, float으로 변수를 선언한 경우 %.2f로 출력하면, 소수점 3째 자리에서 반올림 하여 2째 자리까지 출력할 수 있다.

codeup.kr

 

 

 

 

+ Recent posts