47. 콘솔에서 두 정수(a,b)를 입력 받아 a와b가 같으면 1, 같지않으면 0 을 출력하라.
입력 : 1Line 으로 a,b가 공백을 두고 입력된다.
입력 범위 : -2147483648 ~ 2147483647
입력 예시
9 1
출력 예시
0
JAVA
import java.util.Scanner;
public class Main {
public static void main(String[] args) {
Scanner scan = new Scanner(System.in);
int flagValue = scan.nextInt();
if(flagValue== scan.nextInt()) {
System.out.println(1);
} else {
System.out.println(0);
}
scan.close();
}
}
Swift 4.2
import Foundation
let line = readLine()
if line != nil {
let split = line!.split(separator: " ")
if split.count == 2, let a = Int(split[0]), let b = Int(split[1]) {
print(String.init(format: "%d", (a==b)))
}
}
이전 문제에서 부호만 바꾸었습니다.
https://codeup.kr/problem.php?id=1050
48. 콘솔에서 두 정수(a,b)를 입력 받아 b가 a보다 크거나 같으면1, b가 a보다 작으면 0을 추렭하라
입력 : 1Line 으로 a,b가 공백을 두고 입력된다.
입력 범위 : -2147483648 ~ 2147483647
입력 예시
0 -1
출력 예시
0
JAVA
import java.util.Scanner;
public class Main {
public static void main(String[] args) {
Scanner scan = new Scanner(System.in);
int flagValue = scan.nextInt();
if(flagValue <= scan.nextInt()) {
System.out.println(1);
} else {
System.out.println(0);
}
scan.close();
}
}
Swift 4.2
import Foundation
let line = readLine()
if line != nil {
let split = line!.split(separator: " ")
if split.count == 2, let a = Int(split[0]), let b = Int(split[1]) {
print(String.init(format: "%d", (a<=b)))
}
}
이전 문제의 소스에서 부호만 변경했습니다.
https://codeup.kr/problem.php?id=1051
49. 콘솔에서 두 정수(a,b)를 입력 받아 두 값이 다르면 1 같으면 0을 출력하라.
입력 : 1Line 으로 a,b가 공백을 두고 입력된다.
입력 범위 : -2147483648 ~ 2147483647
입력 예시
0 1
출력 예시
1
Java
import java.util.Scanner;
public class Main {
public static void main(String[] args) {
Scanner scan = new Scanner(System.in);
int flagValue = scan.nextInt();
if(flagValue != scan.nextInt()) {
System.out.println(1);
} else {
System.out.println(0);
}
scan.close();
}
}
Swift 4.2
import Foundation
let line = readLine()
if line != nil {
let split = line!.split(separator: " ")
if split.count == 2, let a = Int(split[0]), let b = Int(split[1]) {
print(String.init(format: "%d", (a != b)))
}
}
이전 문제에서 부호만 변경했습니다.
https://codeup.kr/problem.php?id=1052
'iOS > CodeUP - 기초100 With Swift' 카테고리의 다른 글
1054 : [기초-논리연산] 둘 다 참일 경우만 참 출력하기 with Swift (0) | 2021.05.06 |
---|---|
1053 : [기초-논리연산] 참 거짓 바꾸기 with Swift (0) | 2021.05.06 |
1047, 1048, 1049 [기초-비트시프트연산] 곱셈 with Swift (0) | 2020.05.28 |
1044, 1045, 1046 [기초-산술연산] 합과 평균 with Swift (0) | 2019.07.22 |
1041,1042,1043 [기초-산술연산] 몫,나머지, 다음문자( 아스키 값 ) 연산 with Swift (0) | 2019.07.22 |