52. 콘솔에서 두 정수가 입력될때 둘 중 하나라도 1이 있으면 1을 둘다 0이면 0을 출력하라.
입력 : 1Line 으로 두 정수가 공백을 두고 입력됨
입력 범위 : 0 ~ 1
입력 예시
1 0
출력 예시
1
Java
import java.util.Scanner;
public class Main {
public static void main(String[] args) {
Scanner scan = new Scanner(System.in);
Boolean targetValue = intToBool(scan.nextInt()) || intToBool(scan.nextInt());
scan.close();
System.out.println(boolToInt(targetValue));
}
static boolean intToBool(int value) {
return (value > -1) ? ((value == 0) ? false : true) : false;
}
static int boolToInt(boolean value) {
return value ? 1 : 0;
}
}
Swift 4.2
import Foundation
func intToBool(_ value:Int) -> Bool {
return value > -1 ? (value == 0 ? false : true ): false
}
let line = readLine()
if line != nil {
let values = line!.split(separator: " ")
if values.count == 2 {
if let value0 = Int(values[0]), let value1 = Int(values[1]) {
print(String.init(format: "%d", intToBool(value0) || intToBool(value1)))
}
}
}
이전 소스에서 부호만 변경했습니다.
https://codeup.kr/problem.php?id=1055
'iOS > CodeUP - 기초100 With Swift' 카테고리의 다른 글
1057 : [기초-논리연산] 참/거짓이 서로 같을 때에만 참 출력하기 with Swift (0) | 2021.05.07 |
---|---|
1056 : [기초-논리연산] 참/거짓이 서로 다를 때에만 참 출력하기 with Swift (0) | 2021.05.07 |
1054 : [기초-논리연산] 둘 다 참일 경우만 참 출력하기 with Swift (0) | 2021.05.06 |
1053 : [기초-논리연산] 참 거짓 바꾸기 with Swift (0) | 2021.05.06 |
1050, 1051, 1052 [기초-비교연산] 정수 비교 with Swift (0) | 2020.05.28 |